When adding or updating listings on TradeSquare you may occasionally see listing errors or warnings sent back from TradeSquare.


The table below lists the most common errors/warning messages from TradeSquare, and what you can do to resolve them to ensure any affected product(s) are listed successfully on TradeSquare.


ERROR MESSAGE

POSSIBLE CAUSE
SUGGESTED SOLUTION
The product does not existThe main causes for this are
- a product has been pushed through but wasn’t approved for some error
- a product has been approved by Trade Square but is pending publication, which usually takes 2-3 hours after approval.
If the error remains after 2-3 hours go to the Omnivore Dashboard and hit the "Upload to TradeSquare" button. If the error returns please contact TradeSquare so they can advise of any errors with approval.
1004 | The category could not be identifiedThis caused by the product mapping previously configured directly in your TradeSquare store. Login to your TradeSquare selling account go to the "Product Mapping" tab and remove all product mappings so your products revert to default.
Brand not available on TradeSquareThe brand name needs to be added to the TradeSquare brand database.Contact your Trade Square integration manager with a list of the brands that are not available. When TradeSquare has added the brand names to their database contact Omnivore support so we can update this for you.
Add a default shipping profile warning remains after default shipping profile has been addedThere is a product group assigned to the default shipping profile.Edit the default shipping profile and remove the product group assigned to it. Save your changes and the